Please select To the mobile version | Continue to access the desktop computer version

Foscam BBS

Search
View: 1438|Reply: 44

C1 & C2: No motion detection when behind glass

[Copy link]

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
Post time 2017-03-29 17:59:42 | Show all posts |Read mode
Edited by nigelcam at 2017-03-29 20:06

Neither C1s nor C2s can use motion detection when mounted behind glass due to IR not passing thru glass and Foscam requiring BOTH video AND Infra Red before it will trigger a motion alarm. This occured after their 1st firmware update and I reported it to them in July 2015 however they STILL have not fixed this. See here for my original post.

** Foscam please bring back the ability to enable a motion detection alarm withOUT also requiring PIR triggering.
This was available in the original factory firmware - please return this functionality so we can use motion detection when mounted behind glass!**
(If I could downgrade I would but its not possible after upgrading firmware)

MORE INFO:
FYI: Just (today is 2017/3/30) installed the latest OFFICIAL firmware available on my C1s & C2s however disappointingly Foscam STILL have not fixed the issue of being able to trigger motion detection withOUT the PIR also being triggered.

**So motion detection STILL does NOT work when they are mounted behind glass**

Latest firmware I installed:
C1:
Versions: V-2.x.2.41
Build date: 2017/03/24
System firmware version:1.9.3.18
App firmware version:2.x.2.41
Plug-in version:3.3.0.31

C2:
Versions: V-2.x.1.42
Build date: 2017/03/17
System firmware version:1.11.1.10
App firmware version:2.x.1.42
Plug-in version:3.3.0.31
Reply

Use magic Report

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
 Author| Post time 2017-06-04 18:51:50 | Show all posts
RE C1 v2:
Foscam don't have separate firmware for the v2 on their download page so hopefully the patch may work for your v2 after a factory reset.
NOTE: Remember to have it at the same FW level I had then use the PATCH option to install the patch (not FW upgrade option).

RE How did you manage to get them to provide you with a patch?
I originally reported the problem in the foscam.us forum in July 2015 here (which was Foscam's exclusive US distributor until they started to sell direct) then started this post on their own (foscam.com) forum however like others I have been ignored for 2 years!
The breakthru occured when I emailed tech@foscam.com regarding an unrelated bug with their NVR's firmware (see details below) and during the several emails that followed I raised the C1/C2's IR bug.
It still wasn't easy as they insisted they wanted to remote control my PC to fix this and would NOT make a patch however due to my security conserns regarding someone unknown doing something unknown (they wouldn't tell me what they were going to do) on my network I could not allow this. Finally they relented and made a patch.
I still can't explain why they won't:
  • Acknowledge this bug.
  • Provide this patch on their official FW download site with a note that only those affected should apply it.

FYI: NVR FW bug re UPnP updates sent to Router
Current (as at June 2017) NVR FW updates Router's UPnP table only ONCE after 1st boot up.
This means if you are relying on UPnP to open ports on your router so you can access your NVR externally then you can no longer do this if you happen to power cycle your router untill you also power cycle your NVR. They recently released new FW for the NVRs but you guessed it... still not fixed!
So I have disabled UPnP on all my Foscam devices and manually configured port forwarding on my router.
Its more secure anyway since I no longer trust firmware to open ports in case they do something I'm not aware of.

Reply Support 1 Not support 0

Use magic Report

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
 Author| Post time 2017-06-01 17:14:42 | Show all posts
Hi All,
Apologies for not replying sooner however I had not been monitoring this thread.
OK so it seems a few people are having problems installing the patch so here are a some things you should check/try:

RE Check your firmware versions match mine before installing the patch:
I don't know for sure if the firmware versions have to match mine prior to installing the patches however it's probably safest to match since Foscam requested my firmware versions and made theses patches based on them.
IMPORTANT: To see the screenshots showing my firmware versions (and the patches I uploaded) on the 1st page of this thread here you must login to this forum else they are not displayed (just realised this myself). So if you are reading this forum as a guest you must register and login to see them - sorry I have no control over this.

RE Firmware updates:
Do not look for them at foscam.us as this is no longer the official site, instead always go to foscam.com.
The direct link to the firmware download page is here.  

RE Installing patch:
Make sure you are selecting the option to install a patch not the option to upgrade firmware.

RE Firmware and/or Patch install fails:
Try a "Factory Reset" on your camera before installing new firmware and/or patch.
  • Hardware method:
    Push and hold the WPS/Reset button for more than 10 seconds - the light will be red and blink every 0.4 seconds.
  • Software method:
    Click "Factory Reset" button found in the System page of the camera settings.

Let me know how you go.
Regards Nigel

Reply Support 1 Not support 0

Use magic Report

0

Threads

295

Posts

810

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
810
Post time 2017-03-29 20:00:18 | Show all posts
Hi Nigelcam,

As for your case, please send email to tech@foscam.com, they will check if there is patch can insulate the PIR and motion detection alarm. Thank you
Reply Support Not support

Use magic Report

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
 Author| Post time 2017-03-29 20:15:17 | Show all posts
RE Email tech@foscam.com
I have emailed tech@foscam.com several times regarding this over the last two years and again just this week.
The reply I received (on 2017/3/28) was to tell me to upgrade the firmware which I did (see above for Firmware versions I installed which are latest available to date) but again STILL NOT FIXED!

FYI here is my Ticket #:
Re: [Ticket#2017032343000901] Expected release date for new C1 or C2 Firmware to enable turning OFF PIR
Reply Support Not support

Use magic Report

0

Threads

295

Posts

810

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
810
Post time 2017-03-30 02:10:12 | Show all posts
nigelcam replied at 2017-03-29 20:15
RE Email  
I have emailed  several times regarding this over the last two years and again just this  ...

Hi Nigelcam,

I will ask the tech-specialist to talk with research team about your case, please wait for the email. Thank you.
Reply Support Not support

Use magic Report

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
 Author| Post time 2017-03-30 14:52:04 | Show all posts
I've been waiting for TWO YEARS!
For others that may read this post do NOT think they have fixed this until I report back here that it has.

I've found a new tactic on support forums is to say thinks like "I'll contact you and resolve this" or "I'll ask the tech-specialist to talk with research team about your case..." so that new readers think the problem has been resolved when in fact it hasn't.

So unless I report back here that this problem has been resolved:
DO NOT BUY A C1 OR C2 CAMERA IF MOUNTING BEHIND GLASS AS MOTION DETECTION DOES NOT WORK!
Reply Support Not support

Use magic Report

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
 Author| Post time 2017-04-09 17:04:32 | Show all posts
Reporting back here for anyone following this thread, as suspected there has been NO further response from Foscam re this fault so:

**
DO NOT BUY A C1 OR C2 CAMERA IF MOUNTING BEHIND GLASS AS MOTION DETECTION DOES NOT WORK! **
Reply Support Not support

Use magic Report

4

Threads

18

Posts

179

Credits

Member

Rank: 2

Credits
179
 Author| Post time 2017-04-27 18:13:38 | Show all posts
Edited by nigelcam at 2017-04-27 18:40

After many requests to Foscam they have finally provided me with patches (attached below) for my C1 & C2 cameras.
**This has enabled motion detection to work when they are mounted behind glass**
IMPORTANT:
  • Foscam R&D created these patches for me based on the fact that my C1 & C2s were at the current firmware versions shown in the pictures below so please ensure your cameras are also at these versions before applying the patches otherwise I'm not sure what may happen and worse case is that you could brick your camera.
  • I rebooted my cameras immediately before applying patches just to make sure they were healthy and strongly recommend you do the same.
  • You do NOT need to do a Factory Reset before applying.
  • Use the Patch Installation (NOT System Upgrade) option in the System menu.
  • After installing the patch the C1's Application Firmware Version will NOT change however the C2's will have "_p1" appended to it.
Must have this firmware version installed BEFORE applying patches:

AFTER patching (C1 versions stay same as above, only C2's Application Firmware Version changes):

C1 & C2 Firmware patches:

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply Support Not support

Use magic Report

0

Threads

1

Posts

8

Credits

Newbie

Rank: 1

Credits
8
Post time 2017-04-28 00:54:10 | Show all posts
Thank you very much, nigelcam, for sharing this patch !

Greetings from France !
Reply Support Not support

Use magic Report

0

Threads

9

Posts

34

Credits

Newbie

Rank: 1

Credits
34
Post time 2017-04-30 03:43:04 | Show all posts
Thanks nigelcam.  If I had known about this issue prior, I would not have recently purchased this camera.
Have emailed support for a similar patch.  My camera is C1 V2 so your patch failed to apply for me.
Reply Support Not support

Use magic Report

0

Threads

1

Posts

4

Credits

Newbie

Rank: 1

Credits
4
Post time 2017-04-30 15:49:50 | Show all posts
I checked all the firmware versions on my C1, they match your photos exactly, yet the patch install keeps failing. Any ideas? I'm using a wire connection, and I rebooted prior to attempting the patch install.
Thank you!
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list