Please select To the mobile version | Continue to access the desktop computer version

Foscam BBS

Search
View: 53|Reply: 1

CGIStream FI9901EP failing

[Copy link]

1

Threads

1

Posts

7

Credits

Newbie

Rank: 1

Credits
7
Post time 2017-06-18 02:50:52 | Show all posts |Read mode
I followed the instructions in the forum and Foscam IPCamera CGI User Guide trying to implement the MJPEG Stream into my home automation.

Still I have no luck as it seems
1. Either the SubStream can not be set to MJPEG OR
2. The stream does not work

When trying to set the SubStream I get
  1. http://192.168.xx.xx:88/cgi-bin/CGIProxy.fcgi?usr=admin&pwd=xxx&cmd=setSubStreamFormat&format=1

  2. <CGI_Result>
  3.     <result>-3</result>
  4. </CGI_Result>
Copy the Code
Trying a mix of setMain... & setSub.. returns
  1. http://192.168.xx.xx:88/cgi-bin/CGIProxy.fcgi?usr=admin&pwd=xxx&cmd=setSubStreamFormat&streamType=1

  2. <CGI_Result>
  3.     <result>0</result>
  4. </CGI_Result>
Copy the Code
When trying to access the stream it really confusing: sometimes I get error 500, sometimes the connection get's reset and sometimes "CGI_Result = -3"
  1. http://192.168.xx.xx:88/cgi-bin/CGIStream.fcgi?cmd=GetMJStream&usr=gast&pwd=gast123
Copy the Code

Is there a newer instruction for FI9901EP with the current firmware?
- System: 1.11.1.10
- Application: 2.47.1.48

Reply

Use magic Report

0

Threads

1

Posts

4

Credits

Newbie

Rank: 1

Credits
4
Post time 4 day(s) ago | Show all posts
Hi,
On my FI9928P I have a similar problem.

Command OK : http://192.168.1.34:88/cgi-bin/C ... icolas&pwd=PASS

Command KO : http://192.168.1.34:88/cgi-bin/C ... icolas&pwd=PASS
ERR_EMPTY_RESPONSE


Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list